summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2022-07-17 09:10:59 -0700
committerDavid Lord <davidism@gmail.com>2022-07-17 09:16:47 -0700
commitec4218dde54ef12e676cfb74f7f93d192fd676a2 (patch)
treedffbe2b8afcc7963d060912b191701dcb7a2bf9c
parent16b1519007d88c867ac85d91961d7c616711dd8c (diff)
downloadblinker-ec4218dde54ef12e676cfb74f7f93d192fd676a2.tar.gz
convert readme to rst
-rw-r--r--MANIFEST.in2
-rw-r--r--README.md31
-rw-r--r--README.rst40
-rw-r--r--setup.py2
4 files changed, 42 insertions, 33 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index d07dc17..c889dcc 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,5 +1,5 @@
include LICENSE.rst
-include README.md
+include README.rst
include CHANGES.rst
recursive-include tests *py
recursive-include docs/source *rst *py
diff --git a/README.md b/README.md
deleted file mode 100644
index 2baf51e..0000000
--- a/README.md
+++ /dev/null
@@ -1,31 +0,0 @@
-# Blinker
-
-Blinker provides a fast dispatching system that allows any number of
-interested parties to subscribe to events, or "signals".
-
-Signal receivers can subscribe to specific senders or receive signals
-sent by any sender.
-
-```pycon
->>> from blinker import signal
->>> started = signal('round-started')
->>> def each(round):
-... print "Round %s!" % round
-...
->>> started.connect(each)
-
->>> def round_two(round):
-... print "This is round two."
-...
->>> started.connect(round_two, sender=2)
-
->>> for round in range(1, 4):
-... started.send(round)
-...
-Round 1!
-Round 2!
-This is round two.
-Round 3!
-```
-
-See the [Blinker documentation](https://pythonhosted.org/blinker/) for more information.
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..883dded
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,40 @@
+Blinker
+=======
+
+Blinker provides a fast dispatching system that allows any number of
+interested parties to subscribe to events, or "signals".
+
+Signal receivers can subscribe to specific senders or receive signals
+sent by any sender.
+
+.. code-block:: pycon
+
+ >>> from blinker import signal
+ >>> started = signal('round-started')
+ >>> def each(round):
+ ... print "Round %s!" % round
+ ...
+ >>> started.connect(each)
+
+ >>> def round_two(round):
+ ... print "This is round two."
+ ...
+ >>> started.connect(round_two, sender=2)
+
+ >>> for round in range(1, 4):
+ ... started.send(round)
+ ...
+ Round 1!
+ Round 2!
+ This is round two.
+ Round 3!
+
+
+Links
+-----
+
+- Documentation: https://blinker.readthedocs.io/
+- Changes: https://blinker.readthedocs.io/#changes
+- PyPI Releases: https://pypi.org/project/blinker/
+- Source Code: https://github.com/pallets-eco/blinker/
+- Issue Tracker: https://github.com/pallets-eco/blinker/issues/
diff --git a/setup.py b/setup.py
index 3e63963..e76c03e 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ try:
except ImportError:
from distutils.core import setup
-readme = open('README.md').read()
+readme = open('README.rst').read()
import blinker
version = blinker.__version__