summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBartek Sokorski <b.sokorski@gmail.com>2023-01-19 00:59:39 +0100
committerPhil Jones <philip.graham.jones@googlemail.com>2023-01-22 11:31:40 +0000
commit87ffbe66b7f01f7c24fe545c9e93efec0c2e58d0 (patch)
tree1a68993327b5eb94fc92d24e638898f2fcdb7bed
parentc074cdd06328b724bbe95c060373a57ff2e86b1f (diff)
downloadblinker-87ffbe66b7f01f7c24fe545c9e93efec0c2e58d0.tar.gz
Move to pyproject.toml
-rw-r--r--pyproject.toml48
-rw-r--r--setup.cfg7
-rw-r--r--setup.py35
3 files changed, 48 insertions, 42 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..98a0b20
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,48 @@
+[build-system]
+requires = ["setuptools>=61.2"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "blinker"
+license = {text = "MIT License"}
+authors = [{name = "Jason Kirtland", email = "jek@discorporate.us"}]
+maintainers = [{name = "Pallets Ecosystem", email = "contact@palletsprojects.com"}]
+description = "Fast, simple object-to-object and broadcast signaling"
+keywords = [
+ "signal",
+ "emit",
+ "events",
+ "broadcast",
+]
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Libraries",
+]
+requires-python = ">= 3.7"
+dynamic = ["version"]
+
+[project.urls]
+Homepage = "https://blinker.readthedocs.io"
+Documentation = "https://blinker.readthedocs.io"
+"Source Code" = "https://github.com/pallets-eco/blinker/"
+"Issue Tracker" = "https://github.com/pallets-eco/blinker/issues/"
+Chat = "https://discord.gg/pallets"
+
+[project.readme]
+file = "README.rst"
+content-type = "text/x-rst"
+
+[tool.setuptools]
+license-files = ["LICENSE.rst"]
+include-package-data = false
+
+[tool.setuptools.dynamic]
+version = {attr = "blinker.__version__"}
+
+[tool.pytest.ini_options]
+testpaths = ["tests"]
+filterwarnings = ["error"]
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 01aaea5..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,7 +0,0 @@
-[bdist_wheel]
-universal = 1
-
-[tool:pytest]
-testpaths = tests
-filterwarnings =
- error
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 462ccd3..0000000
--- a/setup.py
+++ /dev/null
@@ -1,35 +0,0 @@
-try:
- from setuptools import setup
-except ImportError:
- from distutils.core import setup
-
-readme = open('README.rst').read()
-import blinker
-version = blinker.__version__
-
-setup(name="blinker",
- version=version,
- packages=['blinker'],
- author='Jason Kirtland',
- author_email='jek@discorporate.us',
- maintainer="Pallets Ecosystem",
- maintainer_email="contact@palletsprojects.com",
- description='Fast, simple object-to-object and broadcast signaling',
- keywords='signal emit events broadcast',
- long_description=readme,
- long_description_content_type="text/x-rst",
- license='MIT License',
- url='https://blinker.readthedocs.io',
- project_urls={
- 'Source': 'https://github.com/pallets-eco/blinker',
- },
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Topic :: Software Development :: Libraries',
- ],
-)