summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2022-07-17 08:54:52 -0700
committerDavid Lord <davidism@gmail.com>2022-07-17 09:16:47 -0700
commit4f7684027bac16b733bab1a6a042864f0851d415 (patch)
tree24916db1a6019f367acc6ea3a7c88d91c08be1be
parentb2e134d762966f561e3c9d229ee90915f3b12109 (diff)
downloadblinker-4f7684027bac16b733bab1a6a042864f0851d415.tar.gz
remove makefile
-rw-r--r--Makefile30
1 files changed, 0 insertions, 30 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index 4e53a9e..0000000
--- a/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-REL=$(shell python -c 'import blinker; print blinker.__version__')
-
-.PHONY: clean sdist clean website docs test
-
-
-release: clean test docs sdist website
- @echo Preparing blinker release $(REL)
- (cd docs/source && make clean)
- (cd docs/source && make doctest)
- (cd docs/source && VERSION=$(REL) make html)
- (cd docs/source && VERSION=$(REL) make text)
- python setup.py sdist --formats=zip
-
-sdist:
- python setup.py sdist
-
-clean:
- (cd docs/source && make clean)
-
-website:
- (cd docs/source && VERSION=$(REL) make website)
-
-docs:
- (cd docs/source && VERSION=$(REL) make html)
- (cd docs/source && VERSION=$(REL) make text)
-
-
-test:
- (cd docs/source && make doctest)
- tox