summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2022-07-17 10:37:27 -0700
committerGitHub <noreply@github.com>2022-07-17 10:37:27 -0700
commit28e19c7e743fb9427afad8f258f844cfdeeb3851 (patch)
tree7c1f4ef2c6ef26a169fe847a9b2e6eab4a4851a8
parent084d2bdb86f7e2e29e4bc88d5317955b9c4d76dc (diff)
parenta45816274eea91428a94184f0e2ffc2f802eeeac (diff)
downloadblinker-28e19c7e743fb9427afad8f258f844cfdeeb3851.tar.gz
Merge pull request #73 from pallets-eco/release-1.51.5
release version 1.5
-rw-r--r--.gitignore21
-rw-r--r--CHANGES.rst2
-rw-r--r--blinker/__init__.py2
-rw-r--r--setup.py3
4 files changed, 18 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
index 3c90d3f..1ca9c16 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,13 @@
-*.py?
-*$py.class
-.coverage
-.tox
-build
-dist
-MANIFEST
-docs/_build
+/.idea/
+/.vscode/
+/venv*/
+/.venv*/
+/env*/
+/.env*/
+__pycache__/
+*.pyc
+/.pytest_cache/
+/.tox/
+/*.egg-info/
+/dist/
+/docs/_build/
diff --git a/CHANGES.rst b/CHANGES.rst
index d123b19..d278ca0 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,7 +1,7 @@
Version 1.5
-----------
-Unreleased
+Released 2022-07-17
- Support Python >= 3.7 and PyPy. Python 2, Python < 3.7, and Jython
may continue to work, but the next release will make incompatible
diff --git a/blinker/__init__.py b/blinker/__init__.py
index 57e1be8..bed55ca 100644
--- a/blinker/__init__.py
+++ b/blinker/__init__.py
@@ -19,4 +19,4 @@ __all__ = [
]
-__version__ = '1.5dev'
+__version__ = '1.5'
diff --git a/setup.py b/setup.py
index 7699c5f..462ccd3 100644
--- a/setup.py
+++ b/setup.py
@@ -12,9 +12,12 @@ setup(name="blinker",
packages=['blinker'],
author='Jason Kirtland',
author_email='jek@discorporate.us',
+ maintainer="Pallets Ecosystem",
+ maintainer_email="contact@palletsprojects.com",
description='Fast, simple object-to-object and broadcast signaling',
keywords='signal emit events broadcast',
long_description=readme,
+ long_description_content_type="text/x-rst",
license='MIT License',
url='https://blinker.readthedocs.io',
project_urls={