summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml10
-rw-r--r--tox.ini2
2 files changed, 7 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 41bab6b..b3ed372 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,15 +3,17 @@ language: python
python:
- 2.6
- 2.7
- - 3.2
+ - 3.3
+ - 3.6
- pypy
matrix:
allow_failures:
- - python: 3.2 # Not a new enough 3.2 for blessings
- python: pypy # PyPy doesn't have _curses.
-script:
- - pip install -q --use-mirrors nose
+install:
+ - pip install -q nose
- python setup.py install
+
+script:
- nosetests -w /tmp blessings.tests
diff --git a/tox.ini b/tox.ini
index 06bd4fd..a8c9b5a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py25, py26, py27, py32, py33
+envlist = py26, py27, py33, py36
[testenv]
commands = nosetests blessings