summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Rose <grinch@grinchcentral.com>2018-01-17 19:52:36 -0500
committerGitHub <noreply@github.com>2018-01-17 19:52:36 -0500
commitdd9dfd21a2d50dd435da0e353025de9d37129da0 (patch)
treede3d74916b6fe75b9a5d880dc73fb8668c887c8b
parent8edd8fd574f3d38628ab5443c903188cb1e1d72f (diff)
parent07f24bd51167077da6e8eff35ac14f520a35b674 (diff)
downloadblessings-dd9dfd21a2d50dd435da0e353025de9d37129da0.tar.gz
Be consistent about the versions of Python we support. Close #128.
-rw-r--r--blessings/__init__.py8
-rw-r--r--setup.py9
2 files changed, 7 insertions, 10 deletions
diff --git a/blessings/__init__.py b/blessings/__init__.py
index 810d367..9e10ebc 100644
--- a/blessings/__init__.py
+++ b/blessings/__init__.py
@@ -14,7 +14,6 @@ except ImportError:
``io.UnsupportedOperation`` in Python 2"""
from os import isatty, environ
-from platform import python_version_tuple
import struct
import sys
from termios import TIOCGWINSZ
@@ -23,13 +22,6 @@ from termios import TIOCGWINSZ
__all__ = ['Terminal']
-if ('3', '0', '0') <= python_version_tuple() < ('3', '2', '2+'): # Good till
- # 3.2.10
- # Python 3.x < 3.2.3 has a bug in which tparm() erroneously takes a string.
- raise ImportError('Blessings needs Python 3.2.3 or greater for Python 3 '
- 'support due to http://bugs.python.org/issue10570.')
-
-
class Terminal(object):
"""An abstraction around terminal capabilities
diff --git a/setup.py b/setup.py
index 0c366e1..caaadee 100644
--- a/setup.py
+++ b/setup.py
@@ -27,6 +27,7 @@ setup(
test_suite='nose.collector',
url='https://github.com/erikrose/blessings',
include_package_data=True,
+ python_requires='>=2.6, !=3.0.*, !=3.1.*, !=3.2.*',
classifiers=[
'Intended Audience :: Developers',
'Natural Language :: English',
@@ -36,11 +37,15 @@ setup(
'License :: OSI Approved :: MIT License',
'Operating System :: POSIX',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.5',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: User Interfaces',
'Topic :: Terminals'