summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Rose <grinch@grinchcentral.com>2018-10-24 13:59:12 -0400
committerGitHub <noreply@github.com>2018-10-24 13:59:12 -0400
commitb1d4daf948d1db8455af64836906785204d09055 (patch)
tree39f87b68700c22bf867b708b1431d190eafbaba9
parentd58e312c9c6ac938e170f9e40fe5a2bda6fd4932 (diff)
parentfeb98cf9f9d48a29c0b9957561ef01179fcd44ef (diff)
downloadblessings-b1d4daf948d1db8455af64836906785204d09055.tar.gz
Merge test-running under 3.7 + new set syntax. Close #139.
-rw-r--r--.travis.yml6
-rw-r--r--blessings/__init__.py12
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
4 files changed, 14 insertions, 7 deletions
diff --git a/.travis.yml b/.travis.yml
index 9132c4d..3e2fcf0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,6 +6,12 @@ python:
- 3.5
- 3.6
- pypy
+# Enable 3.7 without globally enabling sudo and dist: xenial for other build jobs
+matrix:
+ include:
+ - python: 3.7
+ dist: xenial
+ sudo: true
install:
- pip install -q nose
diff --git a/blessings/__init__.py b/blessings/__init__.py
index 779ca09..45e5781 100644
--- a/blessings/__init__.py
+++ b/blessings/__init__.py
@@ -418,14 +418,14 @@ def derivative_colors(colors):
[('on_bright_' + c) for c in colors])
-COLORS = set(['black', 'red', 'green', 'yellow', 'blue', 'magenta', 'cyan',
- 'white'])
+COLORS = {'black', 'red', 'green', 'yellow', 'blue', 'magenta', 'cyan',
+ 'white'}
COLORS.update(derivative_colors(COLORS))
-SINGLES = set(['bold', 'reverse', 'blink', 'dim', 'flash'])
-DUALS = set([
+SINGLES = {'bold', 'reverse', 'blink', 'dim', 'flash'}
+DUALS = {
'underline', 'italic', 'shadow', 'standout', 'subscript', 'superscript'
-])
-COMPOUNDABLES = (COLORS | SINGLES | DUALS | set(['no_' + c for c in DUALS]))
+}
+COMPOUNDABLES = (COLORS | SINGLES | DUALS | {'no_' + c for c in DUALS})
class ParametrizingString(text_type):
diff --git a/setup.py b/setup.py
index 01488fc..6c827bc 100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries',
diff --git a/tox.ini b/tox.ini
index 558601e..30464f2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py{27,34,35,36,py}
+envlist = py{27,34,35,36,37,py}
[testenv]
commands = nosetests blessings