summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2018-10-21 18:55:25 +0300
committerHugo <hugovk@users.noreply.github.com>2018-10-21 18:55:25 +0300
commita2f4f6e5ccf4f1a5bba0f9ee43c6a3237bec9612 (patch)
tree680550fe85c049f324b8d751ece668d18a63632c
parent4e515462ba86483f6e8671bf42241fd39fd27c4e (diff)
downloadblessings-a2f4f6e5ccf4f1a5bba0f9ee43c6a3237bec9612.tar.gz
Add support for Python 3.7
-rw-r--r--.travis.yml6
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 8 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 9132c4d..3e2fcf0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,6 +6,12 @@ python:
- 3.5
- 3.6
- pypy
+# Enable 3.7 without globally enabling sudo and dist: xenial for other build jobs
+matrix:
+ include:
+ - python: 3.7
+ dist: xenial
+ sudo: true
install:
- pip install -q nose
diff --git a/setup.py b/setup.py
index 01488fc..6c827bc 100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries',
diff --git a/tox.ini b/tox.ini
index 558601e..30464f2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py{27,34,35,36,py}
+envlist = py{27,34,35,36,37,py}
[testenv]
commands = nosetests blessings