summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorMarc Abramowitz <marc@marc-abramowitz.com>2012-06-28 15:04:44 -0700
committerMarc Abramowitz <marc@marc-abramowitz.com>2012-06-28 23:16:00 -0700
commit405ac2e46753b04deda102de40be08829bfbff4b (patch)
tree3efda834c23ddba88d15b77890d07d663f9cc2cd /.travis.yml
parent63ca52d91f025ff0664313e5c8ad62007593c4f8 (diff)
downloadblessings-405ac2e46753b04deda102de40be08829bfbff4b.tar.gz
Add .travis.yml for Travis CI (http://travis-ci.org/)
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml18
1 files changed, 18 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..f581b3f
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,18 @@
+language: python
+
+python:
+ - 2.5
+ - 2.6
+ - 2.7
+ - 3.2
+ - pypy
+
+matrix:
+ allow_failures:
+ - python: 3.2
+ - python: pypy
+
+script:
+ - pip install -q --use-mirrors nose
+ - python setup.py install
+ - nosetests -w /tmp blessings.tests