summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonard Richardson <leonardr@segfault.org>2018-12-31 13:02:57 -0500
committerLeonard Richardson <leonardr@segfault.org>2018-12-31 13:02:57 -0500
commita26f4d446429870d158abed6830c00d9f02473e5 (patch)
tree4a4d002a67c9266f32650002f526de0116c8a209
parent059c9d13a69d1298057e4821f83a5c8aead2b8fc (diff)
downloadbeautifulsoup4-a26f4d446429870d158abed6830c00d9f02473e5.tar.gz
Added information to CHANGELOG I forgot to add earlier.
-rw-r--r--CHANGELOG6
-rw-r--r--prepare-release.sh12
2 files changed, 18 insertions, 0 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 05f14a7..b778f6d 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -14,6 +14,12 @@
SoupSieve documentation: https://facelessuser.github.io/soupsieve/
+* Added the PageElement.extend() method, which works like list.append().
+ [bug=1514970]
+
+* PageElement.insert_before() and insert_after() now take a variable
+ number of arguments. [bug=1514970]
+
* Fix a number of problems with the tree builder that caused
trees that were superficially okay, but which fell apart when bits
were extracted. Patch by Isaac Muse. [bug=1782928,1809910]
diff --git a/prepare-release.sh b/prepare-release.sh
index ff3f6c0..729959a 100644
--- a/prepare-release.sh
+++ b/prepare-release.sh
@@ -13,6 +13,18 @@
rm -rf build dist
+# Run this in a Python 2 env and a Python 3 env to make both sdist and
+# wheels.
+python setup.py sdist bdist_wheel
+
+# Run this in Python 3 env.
+twine upload --repository-url https://test.pypi.org/legacy/ dist/*
+
+twine upload dist/*
+
+# Old instructions:
+
+
# Create the 2.x source distro and wheel
python setup.py sdist bdist_wheel