summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Douard <david.douard@logilab.fr>2013-06-17 18:09:03 +0200
committerDavid Douard <david.douard@logilab.fr>2013-06-17 18:09:03 +0200
commitde948487c55093839c6c022bff5f45b195637c3d (patch)
treeea29aee5cf6a39fd566a2a5008bef682813d5a39 /debian
parent71454b097693d33daceb5d83925abfc62c9e12ec (diff)
downloadastroid-de948487c55093839c6c022bff5f45b195637c3d.tar.gz
rename the project astroid
Diffstat (limited to 'debian')
-rw-r--r--debian/control22
-rw-r--r--debian/copyright6
-rw-r--r--debian/python-astroid.dirs1
-rw-r--r--debian/python-logilab-astng.dirs1
-rwxr-xr-xdebian/rules26
-rw-r--r--debian/watch2
6 files changed, 31 insertions, 27 deletions
diff --git a/debian/control b/debian/control
index c33e3e9..267da11 100644
--- a/debian/control
+++ b/debian/control
@@ -1,27 +1,31 @@
-Source: logilab-astng
+Source: astroid
Section: python
Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>, Sandro Tosi <morph@debian.org>
+Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>,
+ Alexandre Fayolle <afayolle@debian.org>,
+ Sandro Tosi <morph@debian.org>
Build-Depends: debhelper (>= 5.0.37.2), python (>= 2.5)
Build-Depends-Indep: python-support
XS-Python-Version: >= 2.5
Standards-Version: 3.8.2
-Homepage: http://www.logilab.org/project/logilab-astng
-Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-astng/trunk/
-Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-astng/trunk/
+Homepage: http://bitbucket/logilab/astroid
+Vcs-Hg: https://bitbucket.org/logilab/astroid
+Vcs-Browser: https://bitbucket.org/logilab/astroid/src
-Package: python-logilab-astng
+Package: python-astroid
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53.0-1)
+Depends: ${python:Depends},
+ ${misc:Depends},
+ python-logilab-common (>= 0.53.0-1),
XB-Python-Version: ${python:Versions}
Description: rebuild a new abstract syntax tree from Python's ast
The aim of this module is to provide a common base representation of
Python source code for projects such as pyreverse or pylint.
.
It rebuilds the tree generated by the _ast module by recursively walking down the
- AST and building an extended ast (let's call it astng ;). The new node classes
+ AST and building an extended ast. The new node classes
have additional methods and attributes for different usages.
- Furthermore, astng builds partial trees by inspecting living objects.
+ Furthermore, astroid builds partial trees by inspecting living objects.
diff --git a/debian/copyright b/debian/copyright
index ccc8860..fa24ec9 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,6 +1,6 @@
This package was debianized by Sylvain Thenault <sylvain.thenault@logilab.fr> Sat, 13 Apr 2002 19:05:23 +0200.
-It was downloaded from ftp://ftp.logilab.org/pub/astng
+It was downloaded from http://bitbucket.org/logilab/astroid
Upstream Author:
@@ -9,9 +9,9 @@ Upstream Author:
Copyright:
- Copyright (c) 2003-2010 LOGILAB S.A. (Paris, FRANCE).
+ Copyright (c) 2003-2013 LOGILAB S.A. (Paris, FRANCE).
http://www.logilab.fr/ -- mailto:contact@logilab.fr
- Copyright (C) 2003-2010 Sylvain Thenault
+ Copyright (C) 2003-2013 Sylvain Thenault
License:
diff --git a/debian/python-astroid.dirs b/debian/python-astroid.dirs
new file mode 100644
index 0000000..64b5569
--- /dev/null
+++ b/debian/python-astroid.dirs
@@ -0,0 +1 @@
+usr/share/doc/python-astroid/test
diff --git a/debian/python-logilab-astng.dirs b/debian/python-logilab-astng.dirs
deleted file mode 100644
index f3feac6..0000000
--- a/debian/python-logilab-astng.dirs
+++ /dev/null
@@ -1 +0,0 @@
-usr/share/doc/python-logilab-astng/test
diff --git a/debian/rules b/debian/rules
index 9734c9b..5dca929 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,21 +12,21 @@
#export DH_VERBOSE=1
build: build-stamp
-build-stamp:
+build-stamp:
dh_testdir
-
+
NO_SETUPTOOLS=1 python setup.py -q build
touch build-stamp
-clean:
+clean:
dh_testdir
dh_testroot
NO_SETUPTOOLS=1 python setup.py clean
- find . -name "*.pyc" -delete
-
+ find . -name "*.pyc" -delete
+
rm -rf build
dh_clean build-stamp
@@ -37,30 +37,30 @@ install: build
dh_installdirs
NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/python-logilab-astng/ \
+ --root=$(CURDIR)/debian/python-astroid/ \
--install-layout=deb
# remove sub-package __init__ file (created in postinst)
- rm debian/python-logilab-astng/usr/lib/python*/*-packages/logilab/__init__.py
+ rm debian/python-astroid/usr/lib/python*/*-packages/logilab/__init__.py
# remove test directory (installed in a separated package)
- rm -rf debian/python-logilab-astng/usr/lib/python*/*-packages/logilab/astng/test
+ rm -rf debian/python-astroid/usr/lib/python*/*-packages/logilab/astroid/test
# install tests
- (cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/python-logilab-astng/usr/share/doc/python-logilab-astng/test/{} \;)
+ (cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/python-astroid/usr/share/doc/python-astroid/test/{} \;)
# Build architecture-independent files here.
binary-indep: build install
- dh_testdir
- dh_testroot
+ dh_testdir
+ dh_testroot
dh_install -i
- dh_pysupport -i
+ dh_pysupport -i
dh_installchangelogs -i ChangeLog
dh_installexamples -i
dh_installdocs -i README
dh_compress -i -X.py -X.ini -X.xml -Xtest
dh_fixperms -i
dh_installdeb -i
- dh_gencontrol -i
+ dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
diff --git a/debian/watch b/debian/watch
index 2476862..85bc900 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,2 +1,2 @@
version=3
-opts=pasv ftp://ftp.logilab.org/pub/astng/logilab-astng-(.*)\.tar\.gz
+https://bitbucket.org/logilab/astroid/downloads /logilab/astroid/get/astroid-version-(.*).tar.gz