summaryrefslogtreecommitdiff
path: root/__pkginfo__.py
diff options
context:
space:
mode:
authorEmile Anclin <emile.anclin@logilab.fr>2010-11-10 11:11:51 +0100
committerEmile Anclin <emile.anclin@logilab.fr>2010-11-10 11:11:51 +0100
commite1932acf3c962f84541c42f047adc8ee02da58b6 (patch)
tree8d6bc17a07d1b643f2a19542ce20d510618376cb /__pkginfo__.py
parentf89fa7a015af039eb87c86d29c40632d6d5083b0 (diff)
downloadastroid-e1932acf3c962f84541c42f047adc8ee02da58b6.tar.gz
packaging : add py3k target; update setup.py and other files to make py3k packaging work
Diffstat (limited to '__pkginfo__.py')
-rw-r--r--__pkginfo__.py16
1 files changed, 1 insertions, 15 deletions
diff --git a/__pkginfo__.py b/__pkginfo__.py
index d9961e1..7fe7c16 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -29,8 +29,6 @@ version = '.'.join([str(num) for num in numversion])
install_requires = ['logilab-common >= 0.52.1']
-pyversions = ["2.3", "2.4", "2.5", '2.6', '2.7']
-
license = 'LGPL'
author = 'Logilab'
@@ -39,19 +37,7 @@ mailinglist = "mailto://%s" % author_email
web = "http://www.logilab.org/project/%s" % distname
ftp = "ftp://ftp.logilab.org/pub/%s" % modname
-short_desc = "rebuild a new abstract syntax tree from Python's ast"
-
-long_desc = """The aim of this module is to provide a common base \
-representation of python source code for projects such as pychecker, pyreverse,
-pylint... Well, actually the development of this library is essentially
-governed by pylint's needs.
-
-It rebuilds the tree generated by the compiler.ast [1] module (python <= 2.4)
-or by the builtin _ast module (python >= 2.5) by recursively walking down the
-AST and building an extended ast (let's call it astng ;). The new node classes
-have additional methods and attributes for different usages.
-Furthermore, astng builds partial trees by inspecting living objects."""
-
+description = "rebuild a new abstract syntax tree from Python's ast"
from os.path import join
include_dirs = [join('test', 'regrtest_data'),