summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-11-06 13:06:41 +0200
committerAlex Grönholm <alex.gronholm@nextday.fi>2022-11-06 13:06:41 +0200
commitda30cc8fbb9fee189cdd283ca88f9d125fd125e4 (patch)
treee0abcdf8bc9bccc57e0d35d5ecb528820b2c0c91
parentf86c159c94412fd5639deb5be6ebd66ae9057138 (diff)
downloadapscheduler-da30cc8fbb9fee189cdd283ca88f9d125fd125e4.tar.gz
Removed unnecessary dependency
Greenlet 2.0.0 final has been released.
-rw-r--r--pyproject.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 841d995..5cff45c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -41,10 +41,7 @@ cbor = ["cbor2 >= 5.0"]
mongodb = ["pymongo >= 4"]
mqtt = ["paho-mqtt >= 1.5"]
redis = ["redis >= 4.0"]
-sqlalchemy = [
- "sqlalchemy >= 1.4.22",
- "greenlet >= 2.0.0a2; python_version >= '3.11'"
-]
+sqlalchemy = ["sqlalchemy >= 1.4.22"]
test = [
"APScheduler[cbor,mongodb,mqtt,redis,sqlalchemy]",
"APScheduler[asyncpg]; python_implementation == 'CPython'",