summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py7
-rw-r--r--tox.ini4
2 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index ccd1e72..e06df91 100644
--- a/setup.py
+++ b/setup.py
@@ -29,13 +29,14 @@ setup(
License :: OSI Approved :: MIT License
Operating System :: OS Independent
Programming Language :: Python :: 2
- Programming Language :: Python :: 2.4
- Programming Language :: Python :: 2.5
Programming Language :: Python :: 2.6
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
- Programming Language :: Python :: 3.1
Programming Language :: Python :: 3.2
+ Programming Language :: Python :: 3.3
+ Programming Language :: Python :: 3.4
+ Programming Language :: Python :: Implementation :: PyPy
+ Programming Language :: Python :: Implementation :: CPython
Topic :: Software Development :: Libraries :: Python Modules
""".split('\n') if c.strip()],
test_suite='test.test_api',
diff --git a/tox.ini b/tox.ini
index 2f94286..0566d7b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py24, py25, py26, py27, py31
+envlist = py26, py27, py32, py33, py34
[testenv]
-commands = python test/test.py
+commands = python setup.py test