summaryrefslogtreecommitdiff
path: root/appdirs.py
diff options
context:
space:
mode:
authorLeonardo Rochael Almeida <leorochael@gmail.com>2017-04-11 11:22:11 -0300
committerLeonardo Rochael Almeida <leorochael@gmail.com>2017-04-11 11:22:11 -0300
commitb0262da2a2dc2654b61842325652d31b77b2af30 (patch)
treea6e509b5159c1795c35136f31370fbc9f01b6ff8 /appdirs.py
parent859eac40ac7d0b5f3260068c4810d027012f0488 (diff)
downloadappdirs-b0262da2a2dc2654b61842325652d31b77b2af30.tar.gz
Don't import appdirs from setup.py
In general, setup.py should never import the code it's trying to install. During a setup.py run, there is no guarantee that importing `appdirs` will actually import the one in the same directory as `setup.py`. Instead, read the version number out of `appdirs.py` by opening it.
Diffstat (limited to 'appdirs.py')
-rw-r--r--appdirs.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/appdirs.py b/appdirs.py
index ae67001..808a2ab 100644
--- a/appdirs.py
+++ b/appdirs.py
@@ -13,8 +13,8 @@ See <http://github.com/ActiveState/appdirs> for details and usage.
# - Mac OS X: http://developer.apple.com/documentation/MacOSX/Conceptual/BPFileSystem/index.html
# - XDG spec for Un*x: http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html
-__version_info__ = (1, 4, 3)
-__version__ = '.'.join(map(str, __version_info__))
+__version__ = "1.4.3"
+__version_info__ = tuple(int(segment) for segment in __version__.split("."))
import sys