summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Rouse <jr@its.to>2020-02-25 14:58:41 -0800
committerGitHub <noreply@github.com>2020-02-25 14:58:41 -0800
commitf8a8e9dcbdcf212f05e610957ba6ff55294049f0 (patch)
tree6ebacf8816951dbdb041a0924bf77bf8c06c777a
parent6d3a2188e0ae793a9f45de735a5cf515613dba27 (diff)
parentc25ab0294551510a5efe4371a7cba1c631873c2a (diff)
downloadappdirs-f8a8e9dcbdcf212f05e610957ba6ff55294049f0.tar.gz
Merge pull request #128 from hugovk/rm-3.4
Drop support for EOL Python 3.4
-rw-r--r--.travis.yml5
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
3 files changed, 4 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 86e834f..7ca3c98 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,12 +2,11 @@ dist: xenial
language: python
python:
- "2.7"
- - "pypy2.7-6.0"
- - "3.4"
+ - "pypy"
- "3.5"
- "3.6"
- "3.7"
- "3.8"
- - "pypy3.5-6.0"
+ - "pypy3"
script: python setup.py test
diff --git a/setup.py b/setup.py
index 50df9c7..16aaeb1 100644
--- a/setup.py
+++ b/setup.py
@@ -28,6 +28,7 @@ setup(
description='A small Python module for determining appropriate ' + \
'platform-specific dirs, e.g. a "user data dir".',
long_description=read('README.rst') + '\n' + read('CHANGES.rst'),
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
@@ -37,7 +38,6 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
diff --git a/tox.ini b/tox.ini
index 524448b..736e201 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py{27,py,34,35,36,37,38,py3}
+envlist = py{27,py,35,36,37,38,py3}
[testenv]
commands = python setup.py test