summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-11-11 10:36:34 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2019-11-11 10:37:49 -0800
commitabd4aea3ace3deb2e1b8db7bae12e1a798301032 (patch)
tree0f4b04421f8794c4aba1900238dbc4b4e08b36fb
parenta54ea98feed0a7593475b94de3a359e9e1fe8fdb (diff)
downloadappdirs-abd4aea3ace3deb2e1b8db7bae12e1a798301032.tar.gz
Add Python 3.8 to the test matrix
-rw-r--r--.travis.yml1
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index ae6a18f..86e834f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,7 @@ python:
- "3.5"
- "3.6"
- "3.7"
+ - "3.8"
- "pypy3.5-6.0"
script: python setup.py test
diff --git a/setup.py b/setup.py
index 3458387..50df9c7 100644
--- a/setup.py
+++ b/setup.py
@@ -41,6 +41,7 @@ setup(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: PyPy',
'Programming Language :: Python :: Implementation :: CPython',
'Topic :: Software Development :: Libraries :: Python Modules',
diff --git a/tox.ini b/tox.ini
index 461569e..524448b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, pypy, py34, py35, py36, py37, pypy3
+envlist = py{27,py,34,35,36,37,38,py3}
[testenv]
commands = python setup.py test