summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-08-28 03:14:36 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-08-28 07:09:34 -0700
commit9f51b813eb4aa924bcaf98a445d1aea72c624eaf (patch)
treee86eee7a4ab13990ffeb7c6d489cc438c81244b7
parent6d0a27856ff5ffef6cedb0cf442cb386edbbbd66 (diff)
downloadappdirs-9f51b813eb4aa924bcaf98a445d1aea72c624eaf.tar.gz
Simplify trove classifier list
Easier to simply define a list of strings instead of processing a big string with split() & strip().
-rw-r--r--setup.py36
1 files changed, 18 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 79a8bf5..9f0f331 100644
--- a/setup.py
+++ b/setup.py
@@ -34,24 +34,24 @@ setup(
description='A small Python module for determining appropriate ' + \
'platform-specific dirs, e.g. a "user data dir".',
long_description=read('README.rst') + '\n' + read('CHANGES.rst'),
- classifiers=[c.strip() for c in """
- Development Status :: 5 - Production/Stable
- Intended Audience :: Developers
- License :: OSI Approved :: MIT License
- Operating System :: OS Independent
- Programming Language :: Python :: 2
- Programming Language :: Python :: 2.6
- Programming Language :: Python :: 2.7
- Programming Language :: Python :: 3
- Programming Language :: Python :: 3.2
- Programming Language :: Python :: 3.3
- Programming Language :: Python :: 3.4
- Programming Language :: Python :: 3.5
- Programming Language :: Python :: 3.6
- Programming Language :: Python :: Implementation :: PyPy
- Programming Language :: Python :: Implementation :: CPython
- Topic :: Software Development :: Libraries :: Python Modules
- """.split('\n') if c.strip()],
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
test_suite='test.test_api',
tests_require=tests_require,
keywords='application directory log cache user',