summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-01-24 17:44:33 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2019-01-24 17:44:35 -0800
commit56eeda7ddfc5703136a72e42671bfe1e9c926abb (patch)
treef6f2def629afda5df7896ab2050537cbd092f16f
parent0a7725ce30fbe6b7a6992458b0ba55f998195a6f (diff)
downloadappdirs-56eeda7ddfc5703136a72e42671bfe1e9c926abb.tar.gz
Use 'dist: xenial' in Travis to simplify configuration
Allows using Python version 3.7 without sudo declarations. Travis officially added support for Xenial on 2018-11-08. https://blog.travis-ci.com/2018-11-08-xenial-release As pypy3 is tested on Travis, add it to tox.ini as well.
-rw-r--r--.travis.yml11
-rw-r--r--tox.ini2
2 files changed, 5 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index df54228..ae6a18f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,15 +1,12 @@
+dist: xenial
language: python
python:
- "2.7"
- - "pypy"
+ - "pypy2.7-6.0"
- "3.4"
- "3.5"
- "3.6"
-
-matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: true
+ - "3.7"
+ - "pypy3.5-6.0"
script: python setup.py test
diff --git a/tox.ini b/tox.ini
index 6d63c90..461569e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, pypy, py34, py35, py36, py37
+envlist = py27, pypy, py34, py35, py36, py37, pypy3
[testenv]
commands = python setup.py test