summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn W. O'Brien <john@saltant.com>2020-08-21 21:37:08 -0400
committerJohn W. O'Brien <john@saltant.com>2020-08-21 21:37:08 -0400
commit381d90dd40abf2e46200855c5bb248f0d68b147c (patch)
tree20bd825ea18dbad6461c83f5a1531909718e0c58
parent699bc891844233847ca6c9cac7c8f8eede2a0eae (diff)
downloadappdirs-381d90dd40abf2e46200855c5bb248f0d68b147c.tar.gz
Explicitly decode appdirs.py as UTF-8
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7c582f6..bda95e3 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
#!/usr/bin/env python
+from io import open
import os
# appdirs is a dependency of setuptools, so allow installing without it.
try:
@@ -9,7 +10,7 @@ import ast
def read(fname):
- inf = open(os.path.join(os.path.dirname(__file__), fname))
+ inf = open(os.path.join(os.path.dirname(__file__), fname), encoding='utf8')
out = "\n" + inf.read().replace("\r\n", "\n")
inf.close()
return out