summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRune Halvorsen <runefh@gmail.com>2010-09-09 17:06:23 +0200
committerRune Halvorsen <runefh@gmail.com>2010-09-09 17:06:23 +0200
commit46b4e8aa66c34cd1a3fe4c710e325d5f938baae2 (patch)
tree0d74bb81e58ad94e7b71b65150edc9bf1e22365e
parentf7bdd5e9b5ebf1d3444bf4877308ba9e96f04556 (diff)
downloadanyjson-46b4e8aa66c34cd1a3fe4c710e325d5f938baae2.tar.gz
Bumped version, updated changelog0.2.5
-rw-r--r--CHANGELOG9
-rw-r--r--anyjson/__init__.py2
-rw-r--r--setup.py2
3 files changed, 10 insertions, 3 deletions
diff --git a/CHANGELOG b/CHANGELOG
index a1f6d01..e785cac 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -38,4 +38,11 @@
* Added support for py-yajl (Thanks Benjamin Anderson)
* Improved benchmark script to test serialization performance and
- to use real life data for tests. \ No newline at end of file
+ to use real life data for tests.
+
+0.2.5
+
+ * Added loads and dumps methods so anyjson can be used interchangably
+ with the stdlib json module. Note: The original methods are still
+ in place. Nothing from the 0.2.4 API is changed, removed or deprecated
+ in this release.
diff --git a/anyjson/__init__.py b/anyjson/__init__.py
index b1253b4..9ff7b44 100644
--- a/anyjson/__init__.py
+++ b/anyjson/__init__.py
@@ -3,7 +3,7 @@ interface"""
import sys
-__version__ = "0.2.4"
+__version__ = "0.2.5"
__author__ = "Rune Halvorsen <runefh@gmail.com>"
__homepage__ = "http://bitbucket.org/runeh/anyjson/"
__docformat__ = "restructuredtext"
diff --git a/setup.py b/setup.py
index e6044c6..036d24f 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@ from setuptools import setup, find_packages
author = "Rune Halvorsen"
email = "runefh@gmail.com"
-version = "0.2.4"
+version = "0.2.5"
desc = """Wraps the best available JSON implementation available in a common interface"""
setup(name='anyjson',