summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Matusiak <numerodix@gmail.com>2021-05-05 14:47:46 +1000
committerMartin Matusiak <numerodix@gmail.com>2021-05-05 14:47:46 +1000
commit4603a4a58c32a1187721829535bcd65d6914863f (patch)
treee86d5e872ee6ccc34239b3b6e709c44d9834f787
parentaf57f7da05cb0c6a91940bf7193039093f94ff7a (diff)
downloadansicolor-4603a4a58c32a1187721829535bcd65d6914863f.tar.gz
add release steps
-rw-r--r--README.rst33
1 files changed, 30 insertions, 3 deletions
diff --git a/README.rst b/README.rst
index 3d7c0a1..8d827fe 100644
--- a/README.rst
+++ b/README.rst
@@ -27,6 +27,8 @@ Installation
$ pip install ansicolor
+You can also download `tarballs from Github`_.
+
Documentation
-------------
@@ -46,9 +48,6 @@ Take a look at the ``demos`` to see what's possible.
$ python -m ansicolor.demos --diff
-.. _`documentation`: https://ansicolor.readthedocs.org/
-
-
Maintenance tasks
-----------------
@@ -122,3 +121,31 @@ Re-formatting code
.. code:: bash
$ black ansicolor tests
+
+
+Release a new version
+^^^^^^^^^^^^^^^^^^^^^
+
+1. Make sure ``develop`` branch is in sync with ``master``.
+2. Make all the changes on ``develop``.
+
+Quality assurance (see steps above for how to):
+
+1. Make sure all tests are passing.
+2. Make sure test coverage has not declined.
+3. Make sure ``tox`` run succeeds on all (installed) interpreters.
+4. Make sure ``flake8`` checker passes.
+5. Make sure ``black`` formatter has no changes to make.
+
+Doing a release:
+
+1. Bump version in ``ansicolor/__init__.py``.
+2. Git tag the new version and push the tag. This allows users/packagers to
+ download an auto-generated zip/tarball of the tagged release from Github.
+3. ``python setup.py sdist``
+4. ``python setup.py bdist_wheel``
+5. ``twine upload dist/*``
+
+
+.. _`documentation`: https://ansicolor.readthedocs.org/
+.. _`tarballs from Github`: https://github.com/numerodix/ansicolor/tags