summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-20 10:25:54 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-11-20 10:25:54 +0100
commitf64648eb1feb8e1b3e248b2fd512579cf52b94b7 (patch)
treebbc7b48d2c04ec55b370aee3486b6de3c344ad78
parent5691dec5ee344aec61dbb812cbe4769fca4f002f (diff)
downloadaioeventlet-f64648eb1feb8e1b3e248b2fd512579cf52b94b7.tar.gz
Add tox.ini to run tests with tox
-rw-r--r--README31
-rw-r--r--tox.ini42
2 files changed, 73 insertions, 0 deletions
diff --git a/README b/README
index 59065d5..5dacfb5 100644
--- a/README
+++ b/README
@@ -25,6 +25,36 @@ or::
python setup.py install
+Run tests
+=========
+
+Run tests with tox
+------------------
+
+The `tox project <https://testrun.org/tox/latest/>`_ can be used to build a
+virtual environment with all runtime and test dependencies and run tests
+against different Python versions (2.6, 2.7, 3.2, 3.3).
+
+For example, to run tests with Python 2.7, just type::
+
+ tox -e py27
+
+To run tests against other Python versions:
+
+* ``py26``: Python 2.6
+* ``py27``: Python 2.7
+* ``py32``: Python 3.2
+* ``py33``: Python 3.3
+* ``py34``: Python 3.4
+
+Run tests manually
+------------------
+
+Run the following command from the directory of the aiogreen project:
+
+ python runtests.py -r
+
+
Changelog
=========
@@ -41,6 +71,7 @@ Version 0.2 (development version)
* Add a suite of automated unit tests
* Fix EventLoop.stop(): don't stop immediatly, but schedule stopping the event
loop with call_soon()
+* Add tox.ini to run tests with tox
2014-11-19: version 0.1
-----------------------
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..f83c6d3
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,42 @@
+[tox]
+envlist = py26,py27,py32,py33,py34
+
+[testenv:py26]
+setenv =
+ TROLLIUSDEBUG = 1
+deps=
+ eventlet
+ trollius
+ unittest2
+commands=python runtests.py -r
+
+[testenv:py27]
+setenv =
+ TROLLIUSDEBUG = 1
+deps=
+ eventlet
+ trollius
+commands=python runtests.py -r
+
+[testenv:py32]
+setenv =
+ TROLLIUSDEBUG = 1
+deps=
+ eventlet
+ trollius
+commands=python runtests.py -r
+
+[testenv:py33]
+setenv =
+ PYTHONASYNCIODEBUG = 1
+deps=
+ asyncio
+ eventlet
+commands=python runtests.py -r
+
+[testenv:py34]
+setenv =
+ PYTHONASYNCIODEBUG = 1
+deps=
+ eventlet
+commands=python runtests.py -r