summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2016-02-22 14:16:40 +0100
committerVictor Stinner <victor.stinner@gmail.com>2016-02-22 14:16:40 +0100
commit9beb32e7d80abd63cebb549a59efbff81518d195 (patch)
treeeea23a70deb7828211c629f18fd06db9efc5ac07
parent0147cf973f2d912488edece13c2b9179aa9b17e4 (diff)
downloadaioeventlet-9beb32e7d80abd63cebb549a59efbff81518d195.tar.gz
drop support for Python 2.6 and 3.2
-rw-r--r--doc/changelog.rst10
-rw-r--r--doc/using.rst11
-rw-r--r--setup.py2
-rw-r--r--tests/__init__.py10
-rw-r--r--tox.ini21
5 files changed, 20 insertions, 34 deletions
diff --git a/doc/changelog.rst b/doc/changelog.rst
index 39b3db5..ef98cd1 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -1,7 +1,15 @@
Changelog
=========
-* aioeventlet API is now considered as stable
+Version 0.5
+-----------
+
+* Unit tests now use the aiotest library.
+* Fix for eventlet used with monkey-patching: inject the original threading
+ module and the original threading.get_ident() function in
+ asyncio.base_events.
+* Drop support for Python 2.6 and Python 3.2. aioeventlet depends on trollius
+ and pip which don't support these Python versions anymore.
2014-12-03: Version 0.4
-----------------------
diff --git a/doc/using.rst b/doc/using.rst
index e310766..0676268 100644
--- a/doc/using.rst
+++ b/doc/using.rst
@@ -123,6 +123,10 @@ API
aioeventlet specific functions:
+.. warning::
+ aioeventlet API is not considered as stable yet.
+
+
yield_future
------------
@@ -282,7 +286,7 @@ Requirements:
needed)
* Python 3.3: need Tulip 0.4.1 or newer (``pip install asyncio``),
but Tulip 3.4.1 or newer is recommended
- * Python 2.6-3.2: need Trollius 0.3 or newer (``pip install trollius``),
+ * Python 2.7: need Trollius 0.3 or newer (``pip install trollius``),
but Trollius 1.0 or newer is recommended
Type::
@@ -298,7 +302,7 @@ Run tests with tox
The `tox project <http://testrun.org/tox/latest/>`_ can be used to build a
virtual environment with all runtime and test dependencies and run tests
-against different Python versions (2.6, 2.7, 3.2, 3.3, 3.4).
+against different Python versions (2.7, 3.3, 3.4, 3.5).
To test all Python versions, just type::
@@ -310,17 +314,16 @@ To run tests with Python 2.7, type::
To run tests against other Python versions:
-* ``py26``: Python 2.6
* ``py27``: Python 2.7
* ``py27_patch``: Python 2.7 with eventlet monkey patching
* ``py27_old``: Python 2.7 with the oldest supported versions of eventlet and
trollius
-* ``py32``: Python 3.2
* ``py33``: Python 3.3
* ``py3_patch``: Python 3 with eventlet monkey patching
* ``py3_old``: Python 3 with the oldest supported versions of eventlet and
tulip
* ``py34``: Python 3.4
+* ``py35``: Python 3.5
Run tests manually
------------------
diff --git a/setup.py b/setup.py
index 8c4b358..9db91a1 100644
--- a/setup.py
+++ b/setup.py
@@ -35,7 +35,7 @@ elif (3, 3) <= sys.version_info < (3, 4):
# Python 3.3: use Tulip
requirements.append('asyncio>=0.4.1')
else:
- # Python 2.6-3.2: use Trollius
+ # Python 2.7: use Trollius
requirements.append('trollius>=0.3')
with open("README") as fp:
diff --git a/tests/__init__.py b/tests/__init__.py
index dd5086b..f43f86a 100644
--- a/tests/__init__.py
+++ b/tests/__init__.py
@@ -4,13 +4,7 @@ try:
import asyncio
except ImportError:
import trollius as asyncio
-try:
- # On Python 2.6, unittest2 is needed to get new features like addCleanup()
- import unittest2
- unittest = unittest2
-except ImportError:
- import unittest
- unittest2 = None
+import unittest
try:
from unittest import mock
except ImportError:
@@ -26,6 +20,6 @@ class TestCase(unittest.TestCase):
self.addCleanup(self.loop.close)
self.addCleanup(asyncio.set_event_loop, None)
- if sys.version_info < (3,) and unittest2 is None:
+ if sys.version_info < (3,):
def assertRaisesRegex(self, *args):
return self.assertRaisesRegexp(*args)
diff --git a/tox.ini b/tox.ini
index a71209e..189db56 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,22 +1,12 @@
[tox]
minversion = 1.4
-envlist = py26,py27,py27_old,py27_patch,py32,py33,py3_patch,py3_old,py34,py35
+envlist = py27,py27_old,py27_patch,py33,py3_patch,py3_old,py34,py35
[testenv]
commands=
python runtests.py -r
python run_aiotest.py -r
-[testenv:py26]
-setenv =
- TROLLIUSDEBUG = 1
-deps=
- aiotest
- eventlet
- mock
- trollius
- unittest2
-
[testenv:py27]
setenv =
TROLLIUSDEBUG = 1
@@ -49,15 +39,6 @@ commands=
python runtests.py -r -m
python run_aiotest.py -r -m
-[testenv:py32]
-setenv =
- TROLLIUSDEBUG = 1
-deps=
- aiotest
- eventlet
- mock
- trollius
-
[testenv:py33]
setenv =
PYTHONASYNCIODEBUG = 1