summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2014-03-22 15:41:23 +0100
committerStefan Behnel <stefan_ml@behnel.de>2014-03-22 15:41:23 +0100
commiteef17bd644e08da28fec308d7afbd7ac61ec39d7 (patch)
treee1bcda61e296df3e55667487e857cda9a6f538f3 /setup.py
parent3337f4834396774d63d3ecaa4ba954912462190b (diff)
downloadpython-lxml-eef17bd644e08da28fec308d7afbd7ac61ec39d7.tar.gz
make setup.py fail hard for unsupported Python versions
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 308dbb75..b2438fc2 100644
--- a/setup.py
+++ b/setup.py
@@ -6,6 +6,10 @@ import fnmatch
# for command line options and supported environment variables, please
# see the end of 'setupinfo.py'
+if sys.version_info < (2, 6) or sys.version_info[:2] in [(3, 0), (3, 1)]:
+ print("This lxml version requires Python 2.6, 2.7, 3.2 or later.")
+ sys.exit(1)
+
try:
from setuptools import setup
except ImportError:
@@ -210,12 +214,9 @@ an appropriate version of Cython installed.
'License :: OSI Approved :: BSD License',
'Programming Language :: Cython',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.4',
- 'Programming Language :: Python :: 2.5',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',