summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Twomey <mick@twomeylee.name>2013-10-15 15:37:22 +0100
committerMichael Twomey <mick@twomeylee.name>2013-10-15 15:37:22 +0100
commit7fb29d07d26242bff4cf9af6f53610c4434e1567 (patch)
tree4e7d51ad6e489fd58a869a5832800c47aa99a505 /setup.py
parenta4d203ccdce86148415725d29bffda5659d1330f (diff)
downloadpyiso8601-7fb29d07d26242bff4cf9af6f53610c4434e1567.tar.gz
Move description into README.rst and add devpi
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py54
1 files changed, 3 insertions, 51 deletions
diff --git a/setup.py b/setup.py
index f89ef27..52e6937 100644
--- a/setup.py
+++ b/setup.py
@@ -1,59 +1,11 @@
+import os
+
try:
from setuptools import setup
except ImportError:
from distutils import setup
-long_description="""Simple module to parse ISO 8601 dates
-
-This module parses the most common forms of ISO 8601 date strings (e.g.
-2007-01-14T20:34:22+00:00) into datetime objects.
-
->>> import iso8601
->>> iso8601.parse_date("2007-01-25T12:00:00Z")
-datetime.datetime(2007, 1, 25, 12, 0, tzinfo=<iso8601.iso8601.Utc ...>)
->>>
-
-Changes
-=======
-
-0.1.5
------
-
-* Wow, it's alive! First update since 2007
-* Moved over to https://bitbucket.org/micktwomey/pyiso8601
-* Add support for python 3. https://code.google.com/p/pyiso8601/issues/detail?id=23 (thanks to zefciu)
-* Switched to py.test and tox for testing
-* Make seconds optional in date format ("1997-07-16T19:20+01:00" now valid). https://bitbucket.org/micktwomey/pyiso8601/pull-request/1/make-the-inclusion-of-seconds-optional-in/diff (thanks to Chris Down)
-* Correctly raise ParseError for more invalid inputs (https://bitbucket.org/micktwomey/pyiso8601/issue/1/raise-parseerror-for-invalid-input) (thanks to manish.tomar)
-
-0.1.4
------
-
-* The default_timezone argument wasn't being passed through correctly,
- UTC was being used in every case. Fixes issue 10.
-
-0.1.3
------
-
-* Fixed the microsecond handling, the generated microsecond values were
- way too small. Fixes issue 9.
-
-0.1.2
------
-
-* Adding ParseError to __all__ in iso8601 module, allows people to import it.
- Addresses issue 7.
-* Be a little more flexible when dealing with dates without leading zeroes.
- This violates the spec a little, but handles more dates as seen in the
- field. Addresses issue 6.
-* Allow date/time separators other than T.
-
-0.1.1
------
-
-* When parsing dates without a timezone the specified default is used. If no
- default is specified then UTC is used. Addresses issue 4.
-"""
+long_description = open(os.path.join(os.path.dirname(__file__), "README.rst")).read()
setup(
name="iso8601",