summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2001-07-02 01:36:20 +0000
committerJames Henstridge <jamesh@src.gnome.org>2001-07-02 01:36:20 +0000
commita1ad6a7ed6eadfd4cee338c7b611c3d424d26ec1 (patch)
tree6a6ba85890774226977fa2d136a7da960679ad82 /configure.in
parentad78644778f2995b323bbd59c3537d9ed8c6b4a2 (diff)
downloadpygtk-a1ad6a7ed6eadfd4cee338c7b611c3d424d26ec1.tar.gz
fix up makefile rules to build the pango module.
2001-07-02 James Henstridge <james@daa.com.au> * Makefile.am (pangomodule_la_SOURCES): fix up makefile rules to build the pango module. * pango.override: changes so that it builds properly. * configure.in: add line to check for pango and set PANGO_CFLAGS and PANGO_LIBS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b5517083..dd563973 100644
--- a/configure.in
+++ b/configure.in
@@ -29,8 +29,13 @@ else
fi
AM_PATH_GLIB_2_0(1.3.7,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],gobject)
+PKG_CHECK_MODULES(PANGO, pango >= 0.17,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)])
AM_PATH_GTK_2_0(1.3.7,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],$extra_mods)
+dnl this is so that automake picks up the SUBSTs. autoconf already has them
+AC_SUBST(PANGO_CFLAGS)
+AC_SUBST(PANGO_LIBS)
+
dnl AM_PATH_GDK_IMLIB(1.8, build_imlib=true, build_imlib=false)
dnl AM_CONDITIONAL(BUILD_IMLIB, $build_imlib)