summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2001-06-29 15:07:35 +0000
committerJames Henstridge <jamesh@src.gnome.org>2001-06-29 15:07:35 +0000
commit12580df967e44849f6a8cf1de81ff988a2f8f03a (patch)
tree15a56d2ce590e07d08e61494ee29248bc7afca87 /configure.in
parent0fae0ecd4c47b0d6612ec4cb97c82540d11cb34e (diff)
downloadpygtk-12580df967e44849f6a8cf1de81ff988a2f8f03a.tar.gz
add code to allow overriding the getter for a single attribute.
2001-06-29 James Henstridge <james@daa.com.au> * codegen/codegen.py (write_getattr): add code to allow overriding the getter for a single attribute. (write_boxed_getattr): same here. * codegen/override.py (Overrides): add code to handle "override_attr" statements in an overrides file. * codegen/codegen.py (write_getattr): add support for overriding the complete getattr method for a GObject class. (write_boxed_getattr): similar change here. * configure.in: require 1.3.7 versions of glib and gtk+. (AC_ARG_ENABLE): fix --disable-thread argument. It was actually looking for --disable-numpy, which causes all kinds of weirdness.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 127b9750..b5517083 100644
--- a/configure.in
+++ b/configure.in
@@ -12,7 +12,7 @@ AC_PROG_LIBTOOL
AM_PATH_PYTHON(2.0)
AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
-AC_ARG_ENABLE(numpy,
+AC_ARG_ENABLE(thread,
[ --disable-thread Disable pygtk threading support],,
enable_thread=no)
@@ -28,8 +28,8 @@ else
AC_MSG_RESULT(no)
fi
-AM_PATH_GLIB_2_0(1.3.6,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],gobject)
-AM_PATH_GTK_2_0(1.3.6,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],$extra_mods)
+AM_PATH_GLIB_2_0(1.3.7,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],gobject)
+AM_PATH_GTK_2_0(1.3.7,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],$extra_mods)
dnl AM_PATH_GDK_IMLIB(1.8, build_imlib=true, build_imlib=false)
dnl AM_CONDITIONAL(BUILD_IMLIB, $build_imlib)