summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2021-09-19 15:00:02 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2021-09-19 15:20:30 +0200
commitf9425cfc040f720acd2c78b200d2b7c868f44d4e (patch)
treea0d779976d428e236b7a1cf109bd8a6a2804e78b /meson.build
parenta0347d8446eb937a36d02d7c905f0d56dce8ff8f (diff)
downloadpygobject-f9425cfc040f720acd2c78b200d2b7c868f44d4e.tar.gz
Drop support for Python 3.6
It will be EOL before the next release. This means Ubuntu 18.04 (without backports) is no longer supported, we will move to Debian Buster as the new oldest tested target.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e1e3cf9d..fd8473a9 100644
--- a/meson.build
+++ b/meson.build
@@ -15,8 +15,8 @@ platform_version = '@0@.0'.format(pygobject_version_major)
pymod = import('python')
python = pymod.find_installation(get_option('python'))
-if python.language_version().version_compare('< 3.6')
- error('Requires Python >= 3.6')
+if python.language_version().version_compare('< 3.7')
+ error('Requires Python >= 3.7')
endif
python_dep = python.dependency()