summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2008-07-14 21:56:55 +0000
committerJohan Dahlin <johan@src.gnome.org>2008-07-14 21:56:55 +0000
commit89133740412019a99bc56c78d2f8286281603d83 (patch)
tree6e5f2bf241e7bd71e6f3a3bb05f889e09b9c0358 /configure.ac
parenta469236b6797441b4051de4aa32375db9bd119f2 (diff)
downloadpygobject-89133740412019a99bc56c78d2f8286281603d83.tar.gz
Bug 448173 – use python-config to get python includes
2008-07-14 Johan Dahlin <johan@gnome.org> Bug 448173 – use python-config to get python includes * configure.ac: Really close the by, patch by Matthias Klose svn path=/trunk/; revision=805
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5986789f..87b57892 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,8 +9,8 @@ m4_define(pygobject_version, pygobject_major_version.pygobject_minor_version.pyg
dnl versions of packages we require ...
m4_define(glib_required_version, 2.8.0)
-m4_define(gio_required_version, 2.15.7)
-m4_define(giounix_required_version, 2.15.7)
+m4_define(gio_required_version, 2.16.0)
+m4_define(giounix_required_version, 2.16.0)
AC_INIT(pygobject, pygobject_version,
[http://bugzilla.gnome.org/enter_bug.cgi?product=pygobject])
@@ -73,7 +73,11 @@ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
AC_MSG_CHECKING([for PySignal_SetWakeupFd in Python.h])
py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+if test -x "$PYTHON-config"; then
+PYTHON_INCLUDES=`$PYTHON-config --includes 2>/dev/null`
+else
PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+fi
old_CPPFLAGS=$CPPFLAGS
CPPFLAGS="-Wall -Werror $PYTHON_INCLUDES"
AC_TRY_COMPILE([#include <Python.h>],