summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOleg Pudeyev <p@users.noreply.github.com>2019-06-30 10:32:49 -0400
committerGitHub <noreply@github.com>2019-06-30 10:32:49 -0400
commite4952a050d07a865611db3df1fc1509c783eabae (patch)
treeaed9a1a38bcf13364b5cbb1c5146257f20f60c4b /setup.py
parent5ec15a3547196fbd397eac0bb24f7f6bb7084b1e (diff)
parenta17b893c8d800c3203ab50a96d868841bc57c9b0 (diff)
downloadpycurl-e4952a050d07a865611db3df1fc1509c783eabae.tar.gz
Merge pull request #580 from p-push/libressl-docs
Explcitly mention LibreSSL and BoringSSL in documentation
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index c4c6fc5..3be0fcb 100644
--- a/setup.py
+++ b/setup.py
@@ -896,8 +896,8 @@ unix_help = '''\
PycURL Unix options:
--curl-config=/path/to/curl-config use specified curl-config binary
--libcurl-dll=[/path/to/]libcurl.so obtain SSL library from libcurl.so
- --openssl-dir=/path/to/openssl/dir path to OpenSSL headers and libraries
- --with-openssl libcurl is linked against OpenSSL
+ --openssl-dir=/path/to/openssl/dir path to OpenSSL/LibreSSL/BoringSSL headers and libraries
+ --with-openssl libcurl is linked against OpenSSL/LibreSSL/BoringSSL
--with-ssl legacy alias for --with-openssl
--with-gnutls libcurl is linked against GnuTLS
--with-nss libcurl is linked against NSS
@@ -910,7 +910,7 @@ PycURL Windows options:
--use-libcurl-dll link against libcurl DLL, if not given
link against libcurl statically
--libcurl-lib-name=libcurl_imp.lib override libcurl import library name
- --with-openssl libcurl is linked against OpenSSL
+ --with-openssl libcurl is linked against OpenSSL/LibreSSL/BoringSSL
--with-ssl legacy alias for --with-openssl
--link-arg=foo.lib also link against specified library
'''