summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2021-08-11 00:34:39 +0800
committerGitHub <noreply@github.com>2021-08-11 00:34:39 +0800
commit60035a9ef6bcd856df8b57f980db79d18e3c44fc (patch)
treef532bf8f0c1398f66d6f5cf55e67f2ef16219257 /setup.py
parent9b5d496412951a5e905f98ee659fb1aaf1f42d76 (diff)
downloadpycurl-60035a9ef6bcd856df8b57f980db79d18e3c44fc.tar.gz
Prefer setuptools.setup
Let's always prefer setuptools.setup as it generates better metadata, and fixes the following warning: ``` /usr/lib/python3.9/distutils/dist.py:274: UserWarning: Unknown distribution option: 'python_requires' warnings.warn(msg) ```
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e1abd89..41fa8b5 100644
--- a/setup.py
+++ b/setup.py
@@ -11,9 +11,7 @@ VERSION = "7.44.0"
import glob, os, re, sys, subprocess
import distutils
try:
- import wheel
- if wheel:
- from setuptools import setup
+ from setuptools import setup
except ImportError:
from distutils.core import setup
from distutils.extension import Extension