summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 808e34a..a93a650 100755
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,12 @@ def pkg_config_version_check(pkg, version):
raise SystemExit(pipe.stderr.read().decode())
def pkg_config_parse(opt, pkg):
+ check = "pkg-config %s %s" % (opt, pkg)
pipe = call("pkg-config %s %s" % (opt, pkg))
+ if pipe.returncode != 0:
+ print(check, ' Failed')
+ raise SystemExit(pipe.stderr.read().decode())
+
output = pipe.stdout.read()
output = output.decode() # get the str
opt = opt[-2:]