summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Henningsson <david.henningsson@canonical.com>2011-11-25 15:17:12 +0100
committerTanu Kaskinen <tanuk@iki.fi>2011-11-26 16:46:42 +0200
commitd9685ec85db3722bf3988a64dda4d8ee21c7777b (patch)
treef6b18445054983e4c1ecbd1bdeb2af8b3917a93b /src/Makefile.am
parent961ec210a676e768902956218ff50bfac26dae65 (diff)
downloadpulseaudio-d9685ec85db3722bf3988a64dda4d8ee21c7777b.tar.gz
Turn device ports into reference counted objects
Since both cards and sinks can hold references to a port, it makes sense to reference count them. Although no current implementation actually has sinks with ports but without a card, it felt wrong to make it harder to make such an implementation in the future. Signed-off-by: David Henningsson <david.henningsson@canonical.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5d63aec52..17653acee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -826,6 +826,7 @@ libpulsecore_@PA_MAJORMINOR@_la_SOURCES = \
pulsecore/shared.c pulsecore/shared.h \
pulsecore/sink-input.c pulsecore/sink-input.h \
pulsecore/sink.c pulsecore/sink.h \
+ pulsecore/device-port.c pulsecore/device-port.h \
pulsecore/sioman.c pulsecore/sioman.h \
pulsecore/sound-file-stream.c pulsecore/sound-file-stream.h \
pulsecore/sound-file.c pulsecore/sound-file.h \