summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Small <csmall@dropbear.xyz>2022-09-28 17:42:17 +1000
committerCraig Small <csmall@dropbear.xyz>2022-09-28 17:46:52 +1000
commitf9f5f6ad38ede32eba6c49ef4b8316d381686f3a (patch)
tree5e90903aa1bff4e2d8d8b9f0101b59f0a54b1c5b /configure.ac
parent4b607edc12860c024a5f03f808eccb7079164cb2 (diff)
downloadprocps-ng-f9f5f6ad38ede32eba6c49ef4b8316d381686f3a.tar.gz
build-sys: Allow enable-watch9bit and with-ncurses
The commit that changed configure.ac was supposed to check for when someone removes ncurses using the flag --without-ncurses Unfortunately the change didn't check if the user was specifying --without or --with meaning if they didn use --with-ncurses the configure script would error out. Signed-off-by: Craig Small <csmall@dropbear.xyz> References: commit 812864181408398af98b217f384205a6f2f9cb68 procps-ng/procps#251
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 93670fc..629881a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,13 +219,13 @@ AC_SUBST([HARDEN_LDFLAGS])
# Optional packages - AC_ARG_WITH
AC_ARG_WITH([ncurses],
AS_HELP_STRING([--without-ncurses], [build only applications not needing ncurses]),
- [AS_IF([test "x$enable_watch8bit" = "xyes"],
- [AC_MSG_ERROR([Cannot have both --enable-watch8bit and --without-ncurses])]
- )],
+ [],
[with_ncurses=yes]
)
if test "x$with_ncurses" = xno; then
AM_CONDITIONAL(WITH_NCURSES, false)
+ AS_IF([test "x$enable_watch8bit" = "xyes"],
+ [AC_MSG_ERROR([Cannot have both --enable-watch8bit and --without-ncurses])])
else
AM_CONDITIONAL(WITH_NCURSES, true)
PKG_CHECK_MODULES([NCURSES], [ncursesw],