summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2017-03-13 03:00:00 -0500
committerCraig Small <csmall@enc.com.au>2017-03-16 22:08:07 +1100
commitf318be467b906f021ac405c88e704a2a56fc269b (patch)
tree898abcba519114274dc5d0cda8466bdb28575c8c /configure.ac
parent7468e229e8692142ee955cb3d4cb3084ec3c7450 (diff)
downloadprocps-ng-f318be467b906f021ac405c88e704a2a56fc269b.tar.gz
top: show fewer decimal places for memory (by default)
After much reflection I've come to the conclusion that displaying 3 decimal places (usually) when memory data had been scaled is no longer optimal with today's ever increasing amounts. And given that not all task memory fields are the same widths, inconsistencies can easily arise as illustrated and discussed in the issue below. Instead of unilaterally reducing the number of decimal places, this commit will sneak in such a change via an existing configure option that was very likely unused. The former 'disable-wide-memory' option has now become 'enable-wide-memory', which can be used if the current behavior (3 decimal places) is preferred. Without that option, whenever memory is scaled beyond KiB, just one decimal place will be shown in Summary and Task areas. And Task area field width will no longer be changed by this revised configure option. Instead, all such field widths will now be fixed at the former maximum values. Reference(s): https://gitlab.com/procps-ng/procps/issues/50 [ this patch has been adapted from the master branch ] Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index adc01ff..72ab273 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,11 +223,11 @@ if test "x$enable_wide_percent" = xyes; then
fi
AC_ARG_ENABLE([wide-memory],
- AS_HELP_STRING([--disable-wide-memory], [disable extra precision under memory fields for top]),
- [], [enable_wide_memory=yes]
+ AS_HELP_STRING([--enable-wide-memory], [provide extra precision under memory fields for top]),
+ [], [enable_wide_memory=no]
)
-if test "x$enable_wide_memory" = xno; then
- AC_DEFINE(NOBOOST_MEMS, 1, [disable extra precision under memory fields for top])
+if test "x$enable_wide_memory" = xyes; then
+ AC_DEFINE(BOOST_MEMORY, 1, [provide extra precision under memory fields for top])
fi
AC_ARG_ENABLE([modern-top],