summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Forney <mforney@mforney.org>2013-10-01 02:36:58 +0000
committerJaromir Capik <jcapik@redhat.com>2014-08-28 13:39:22 +0200
commitd6a3a3d97ec58d20eab1a60cc6010cff48b5be3b (patch)
treefdda3c2b79d9100fd2c0562dfcae24f635d5462e /configure.ac
parent2f975ba49dbbb3ded655d5e400b42ae3415f52d1 (diff)
downloadprocps-ng-d6a3a3d97ec58d20eab1a60cc6010cff48b5be3b.tar.gz
Handle 'none required' result from AC_SEARCH_LIBS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 81bf596..8de2535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,7 +243,9 @@ if test "x$enable_numa" = xno; then
else
AC_SEARCH_LIBS([dlopen], [dl], [],
[AC_MSG_ERROR([dynamic linking unavailable, circumvent with --disable-numa])])
- DL_LIB="$ac_cv_search_dlopen"
+ if test "x$ac_cv_search_dlopen" != "xnone required"; then
+ DL_LIB="$ac_cv_search_dlopen"
+ fi
fi
AC_SUBST([DL_LIB])