summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2014-06-29 00:00:00 -0500
committerCraig Small <csmall@enc.com.au>2014-07-01 21:30:46 +1000
commit8ef6cd91fc5df6372a93bc4a37cbad34ead9654e (patch)
tree62bde0451be545cc3d1e218da93c53db2a036c64 /configure.ac
parent2199af404a92cac238728564f2f022255c5716ce (diff)
downloadprocps-ng-8ef6cd91fc5df6372a93bc4a37cbad34ead9654e.tar.gz
top: retire old stale startup defaults in favor of new
For over a decade top has used a startup configuration mimicking the original redhat top. This decision dates back to when the forked Sourceforge version was trying to win over users in battles with that ancient kludge. Will anybody deny that those defaults are coyote ugly? Well, it is time that top presented a more modern look at startup, providing that no saved rcfile exists. But just in case some distro prefers that old, comfortable look, there's the '--disable-modern-top' build option. [ Pssst. With the widened memory fields it turns out ] [ the 'Mem' default window had become almost useless ] [ on an 80x24 terminal since %CPU & COMMAND were out ] [ of view. So some other defaults were tweaked a bit ] [ whether or not --disable-modern-top was specified. ] Reference(s) http://www.freelists.org/post/procps/tops-graph-mode-saga-continues,3 Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 47e965a..ef48e58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -225,6 +225,14 @@ if test "x$enable_wide_memory" = xno; then
AC_DEFINE(NOBOOST_MEMS, 1, [disable extra precision under memory fields for top])
fi
+AC_ARG_ENABLE([modern-top],
+ AS_HELP_STRING([--disable-modern-top], [disable new startup defaults, return to original top]),
+ [], [enable_modern_top=yes]
+)
+if test "x$enable_modern_top" = xno; then
+ AC_DEFINE(ORIG_TOPDEFS, 1, [disable new startup defaults, return to original top])
+fi
+
DL_LIB=
AC_ARG_ENABLE([numa],
AS_HELP_STRING([--disable-numa], [disable NUMA/Node support in top]),