summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Small <csmall@enc.com.au>2015-07-09 23:11:40 +1000
committerCraig Small <csmall@enc.com.au>2015-07-09 23:11:40 +1000
commit5e73c832623cc99442a5d5bc2100b4d7ad323eb8 (patch)
treeb8be48b93f34ca2ab6d56ceddfca755299679743 /configure.ac
parent4e7f42375a9aa860365e6007a53a357df60964f1 (diff)
downloadprocps-ng-5e73c832623cc99442a5d5bc2100b4d7ad323eb8.tar.gz
build-sys: Clean up libsystemd in configure
The previous commit got rid of some but not all the library. The format of it was a little odd with the library being explicitly defined instead of letting autoconf do it for you.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 4 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 48d4a59..675e218 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,19 +149,11 @@ AC_ARG_WITH([systemd],
[AS_HELP_STRING([--with-systemd], [enable systemd support])],
[], [with_systemd=no]
)
-if test "x$with_systemd" != xno; then
- PKG_CHECK_MODULES([SYSTEMD], [libsystemd], [], [
- AC_CHECK_LIB(systemd, sd_pid_get_slice, [have_systemd=yes], [have_systemd=no])
- if test "x$have_systemd" = xno; then
- AC_MSG_ERROR([systemd support missing/incomplete (requires >= 209)])
- fi
- SYSTEMD_LIBS="-lsystemd-login"
- ])
- AM_CONDITIONAL(WITH_SYSTEMD, true)
+AS_IF([test "x$with_systemd" != "xno"], [
+ PKG_CHECK_MODULES([SYSTEMD], [libsystemd])
AC_DEFINE(WITH_SYSTEMD, 1, [enable systemd support])
-else
- AM_CONDITIONAL(WITH_SYSTEMD, false)
-fi
+])
+AM_CONDITIONAL([WITH_SYSTEMD], [test x$with_systemd != xno])
# AC_ARG_ENABLEs
AC_ARG_ENABLE([pidof],