summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Small <csmall@dropbear.xyz>2021-02-15 21:36:57 +1100
committerCraig Small <csmall@dropbear.xyz>2021-02-15 21:36:57 +1100
commit10c6b859b0a1a386bdfcf621481a3279c6d5e0d5 (patch)
tree7e50c2f2abb94d90fdf186545fd0b3f5071e3fe9 /configure.ac
parentfb0e4f3f68d933eee98daff896ad8799e1fc06b0 (diff)
downloadprocps-ng-10c6b859b0a1a386bdfcf621481a3279c6d5e0d5.tar.gz
build-sys: Update building of translations
newlib was lagging behind oldlib in how the build system created the translation files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84f0f18..91f6848 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,18 @@ AC_PROG_LN_S
PKG_PROG_PKG_CONFIG
AC_PROG_MAKE_SET
+AC_DEFUN([PROCPS_PROG_PO4A], [
+ AC_REQUIRE([AM_NLS])
+ AC_CHECK_PROGS([PO4A], [po4a])
+ AS_IF([test "$USE_NLS" = "yes" && test -n "$PO4A"], [
+ USE_PO4A=yes
+ ], [
+ USE_PO4A=no
+ ])
+ AC_SUBST([USE_PO4A])
+])
+PROCPS_PROG_PO4A
+
# Checks for header files.
AC_HEADER_MAJOR
AC_CHECK_HEADERS([arpa/inet.h fcntl.h float.h langinfo.h libintl.h limits.h locale.h stdint.h stdio_ext.h stdlib.h string.h sys/file.h sys/ioctl.h sys/param.h sys/time.h termios.h unistd.h utmp.h utmpx.h values.h wchar.h wctype.h])