summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCraig Small <csmall@enc.com.au>2015-09-26 09:13:13 +1000
committerCraig Small <csmall@enc.com.au>2015-09-26 09:13:13 +1000
commitf65121ef74f2792b4ed0e4e457e85d55eb5a80ef (patch)
tree126e8a0c83b0902abe771f82b4def7172565795c /Makefile.am
parentf37e5eec961417c107fa4beb5546e703023d3826 (diff)
downloadprocps-ng-f65121ef74f2792b4ed0e4e457e85d55eb5a80ef.tar.gz
kill: split out from skill/snice
The first part of fixing skill/snice to use the library instead of directly readdir()ing /proc which is what it does now. Remove the kill code from the skill/snice code and put common elements into lib/signals.c Not 100% sure that is the right destination instead of a new lib file, but ok for now. kill shares some parsing logic with skill/snice but mainly around signal specifications. The "do it" code is very different. Signed-off-by: Craig Small <csmall@enc.com.au>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1efa332..e48f0aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,7 +78,7 @@ endif
if BUILD_KILL
bin_PROGRAMS += kill
dist_man_MANS += kill.1
-kill_SOURCES = skill.c lib/strutils.c lib/fileutils.c lib/signals.c
+kill_SOURCES = kill.c lib/strutils.c lib/fileutils.c lib/signals.c
else
EXTRA_DIST += kill.1
endif