summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCraig Small <csmall@enc.com.au>2018-03-01 21:25:04 +1100
committerCraig Small <csmall@enc.com.au>2018-03-01 21:47:57 +1100
commite72f30549b68115ca8107cf02be93f137a1e8306 (patch)
tree0084528b96c842998190d10b6240b1b357c95d03 /Makefile.am
parent20ce03e08c4d657800f37207af27dea3ab5561c3 (diff)
downloadprocps-ng-e72f30549b68115ca8107cf02be93f137a1e8306.tar.gz
sysctl: Bring procio functions out of library
The procio functions that were in the library have been moved into sysctl. sysctl is not linked to libprocps in newlib and none of the other procps binaries would need to read/write large data to the procfs. References: be6b048a41b0a47ebed602d9e0993fe18c9de237
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ebda189..1f79d82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -210,7 +210,11 @@ pmap_SOURCES = pmap.c lib/fileutils.c
if !CYGWIN
pwdx_SOURCES = pwdx.c lib/fileutils.c
pwdx_LDADD= $(CYGWINFLAGS)
-sysctl_SOURCES = sysctl.c lib/fileutils.c
+sysctl_SOURCES = \
+ sysctl.c \
+ lib/fileutils.c \
+ procio.c \
+ procio.h
sysctl_LDADD=
endif
tload_SOURCES = tload.c lib/strutils.c lib/fileutils.c
@@ -252,8 +256,6 @@ proc_libprocps_la_SOURCES = \
proc/numa.h \
proc/pids.c \
proc/pids.h \
- proc/procio.c \
- proc/procio.h \
proc/procps.h \
proc/pwcache.c \
proc/pwcache.h \
@@ -284,7 +286,6 @@ proc_libprocps_la_include_HEADERS = \
proc/namespace.h \
proc/numa.h \
proc/pids.h \
- proc/procio.h \
proc/procps.h \
proc/pwcache.h \
proc/readproc.h \