summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2016-08-05 00:00:00 -0500
committerCraig Small <csmall@enc.com.au>2016-08-07 21:40:48 +1000
commite3270d463de7eebd9f5ae20c85495e3cb5b69a9f (patch)
treef818e1a1d95fe4ec980fb8e29f97fa01b566473b /Makefile.am
parente0515e23e718094d5651966f672aa241f53d9381 (diff)
downloadprocps-ng-e3270d463de7eebd9f5ae20c85495e3cb5b69a9f.tar.gz
library: provide for validating result type references
During development, we now have a means for validating that a type referenced in application code matches the actual type set by the library. The new feature can be activated through either of the following two methods: 1) ./configure CFLAGS='-DXTRA_PROCPS_DEBUG' (all pgms) 2) an #include <proc/xtra-procps-debug.h> (single pgm) [ in the future, one could add a formal configure.ac ] [ provision. but for now a manual approach is safer. ] Lastly, for any module which provides a sort function, the handling for both 'noop' & 'extra' enumerators was made consistent. Now, 'noop' is not sorted and 'extra' will be sorted as that module's widest supported type. Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ae072b7..a2cb7ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -206,7 +206,8 @@ proc_libprocps_la_SOURCES = \
proc/wchan.c \
proc/wchan.h \
proc/uptime.c \
- proc/uptime.h
+ proc/uptime.h \
+ proc/xtra-procps-debug.h
proc_libprocps_la_includedir = $(includedir)/proc/
proc_libprocps_la_include_HEADERS = \
@@ -223,7 +224,8 @@ proc_libprocps_la_include_HEADERS = \
proc/uptime.h \
proc/version.h \
proc/vmstat.h \
- proc/wchan.h
+ proc/wchan.h \
+ proc/xtra-procps-debug.h
dist_man_MANS += \
proc/openproc.3 \