summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-02-23 22:02:59 -0500
committerCraig Small <csmall@dropbear.xyz>2020-12-22 13:13:32 +1100
commitc8384e682c1cfb3b2dc797e0f8a3cbaaccf7a3da (patch)
tree97d3b6d44574b4cd68f9436b491ef31cfd4635a6 /Makefile.am
parent9f33a6bcd0bc2f0aac7ccaa686d061ea1297f4b1 (diff)
downloadprocps-ng-c8384e682c1cfb3b2dc797e0f8a3cbaaccf7a3da.tar.gz
pgrep: add pwait
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 13564da..815023b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,6 +54,9 @@ bin_PROGRAMS = \
uptime \
vmstat \
w
+if BUILD_PWAIT
+bin_PROGRAMS += pwait
+endif
else
usrbin_exec_PROGRAMS += \
ps/pscommand \
@@ -88,6 +91,10 @@ dist_man_MANS += \
sysctl.8 \
sysctl.conf.5 \
ps/ps.1
+
+if BUILD_PWAIT
+dist_man_MANS += pwait.1
+endif
endif
EXTRA_DIST = \
@@ -201,6 +208,9 @@ free_SOURCES = free.c lib/strutils.c lib/fileutils.c
pgrep_SOURCES = pgrep.c lib/fileutils.c lib/signals.c
pkill_SOURCES = pgrep.c lib/fileutils.c lib/signals.c
pmap_SOURCES = pmap.c lib/fileutils.c
+if BUILD_PWAIT
+pwait_SOURCES = pgrep.c lib/fileutils.c lib/nsutils.c
+endif
if !CYGWIN
pwdx_SOURCES = pwdx.c lib/fileutils.c
pwdx_LDADD= $(CYGWINFLAGS)