summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2018-04-01 00:00:00 -0600
committerCraig Small <csmall@enc.com.au>2018-05-06 07:19:37 +1000
commitc2a29d370cdc1e80ca5f571c092206a478884334 (patch)
tree15ce132bfb32e8c819f7dd622411c992668af4a2 /Makefile.am
parent5d8746b94190f33cc971f17cbef863daf2121e1f (diff)
downloadprocps-ng-c2a29d370cdc1e80ca5f571c092206a478884334.tar.gz
sysctl: relocate the procio code to a more proper home
Now that the procio logic was removed from the library we must move the header file, lest we break make dist. In the process, we will relocate that source file too. [ we'll take a slightly different approach than that ] [ used under the master branch by exploiting those 2 ] [ non-library directories 'include' and 'lib', while ] [ avoiding any sysctl hard coded function prototype. ] Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1f79d82..ac43ad1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -213,8 +213,7 @@ pwdx_LDADD= $(CYGWINFLAGS)
sysctl_SOURCES = \
sysctl.c \
lib/fileutils.c \
- procio.c \
- procio.h
+ lib/procio.c
sysctl_LDADD=
endif
tload_SOURCES = tload.c lib/strutils.c lib/fileutils.c