summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCraig Small <csmall@enc.com.au>2016-04-19 21:33:02 +1000
committerCraig Small <csmall@enc.com.au>2016-04-19 21:33:02 +1000
commitaa16ab0dc18df9f9e49554eb0ce8eefbf0a5cf22 (patch)
treeba5e430f0b6c780afbc2dcbf44a4aad4c4ce1b3f /Makefile.am
parent714ea69c6d18d62572d553ebcbb6d74f73ee55b0 (diff)
downloadprocps-ng-aa16ab0dc18df9f9e49554eb0ce8eefbf0a5cf22.tar.gz
tests: update template and add pids
Generalised the library API tests and created a common test-runner. Instead of copy and pasting the same code in each time. First cut of pids API test, for _new so far.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 42a67e5..77e34f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -269,6 +269,8 @@ proc_test_sysinfo_SOURCES = proc/test_sysinfo.c
proc_test_sysinfo_LDADD = proc/libprocps.la
proc_test_namespace_SOURCES = proc/test_namespace.c
proc_test_namespace_LDADD = proc/libprocps.la
+proc_test_pids_SOURCES = proc/test_pids.c
+proc_test_pids_LDADD = proc/libprocps.la
proc_test_uptime_SOURCES = include/tests.h proc/test_uptime.c
proc_test_uptime_LDADD = proc/libprocps.la
proc_test_version_SOURCES = include/tests.h proc/test_version.c
@@ -283,6 +285,7 @@ endif
BUILT_SOURCES = $(top_srcdir)/.version
TESTS = proc/test_sysinfo \
+ proc/test_pids \
proc/test_namespace \
proc/test_uptime \
proc/test_version \