summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCraig Small <csmall@dropbear.xyz>2022-11-10 21:52:19 +1100
committerCraig Small <csmall@dropbear.xyz>2022-11-10 21:52:19 +1100
commit5ed8add969b51665794b827b9590040fa209a3a0 (patch)
treee3bba97d73da308de3128e5fb42e6b0ef03368d7 /Makefile.am
parentc92da2adc5d8bb4282ca210e4a20a552daa00c42 (diff)
downloadprocps-ng-5ed8add969b51665794b827b9590040fa209a3a0.tar.gz
nls: Update the man-po logic
Put the man-po pot file under version control like its po/*.pot sibling. Makefile now auto-matically generates the list of man pages as they are in a single directory. There were some missing! pot file target is dependent on the untranslated man pages When downloading from translation project, run po4a to sync the new po files correctly. Downloaded man po files from translation project and synched. Thanks to @gorean for the info References: procps-ng/procps#258 Signed-off-by: Craig Small <csmall@dropbear.xyz>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9bcd08d..081cc91 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -411,3 +411,5 @@ get-trans:
echo "Getting the latest translations from translationproject.org..."
rsync -Lrtvz translationproject.org::tp/latest/procps-ng/ po
rsync -Lrtvz translationproject.org::tp/latest/procps-ng-man/ po-man
+ rm -f po-man/man.stamp
+ make -C po-man man.stamp