summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Paquier <michael@paquier.xyz>2023-03-17 10:52:26 +0900
committerMichael Paquier <michael@paquier.xyz>2023-03-17 10:52:26 +0900
commit98ae2c84a49e45c0434c7e1a55bb2fc71582f561 (patch)
tree3ddec78b699eacf8ff0cef77aa76a938b1b8c6c4 /meson.build
parent10b6745d313c6e8f3523306d3d415c57c9039c5d (diff)
downloadpostgresql-98ae2c84a49e45c0434c7e1a55bb2fc71582f561.tar.gz
libpq: Remove code for SCM credential authentication
Support for SCM credential authentication has been removed in the backend in 9.1, and libpq has kept some code to handle it for compatibility. Commit be4585b, that did the cleanup of the backend code, has done so because the code was not really portable originally. And, as there are likely little chances that this is used these days, this removes the remaining code from libpq. An error will now be raised by libpq if attempting to connect to a server that returns AUTH_REQ_SCM_CREDS, instead. References to SCM credential authentication are removed from the protocol documentation. This removes some meson and configure checks. Author: Michael Paquier Reviewed-by: Tom Lane Discussion: https://postgr.es/m/ZBLH8a4otfqgd6Kn@paquier.xyz
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 0 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 2ebdf914c1..7f76a101ec 100644
--- a/meson.build
+++ b/meson.build
@@ -2144,20 +2144,6 @@ foreach c : decl_checks
endforeach
-if cc.has_type('struct cmsgcred',
- args: test_c_args + ['@0@'.format(cdata.get('HAVE_SYS_UCRED_H')) == 'false' ? '' : '-DHAVE_SYS_UCRED_H'],
- include_directories: postgres_inc,
- prefix: '''
-#include <sys/socket.h>
-#include <sys/param.h>
-#ifdef HAVE_SYS_UCRED_H
-#include <sys/ucred.h>
-#endif''')
- cdata.set('HAVE_STRUCT_CMSGCRED', 1)
-else
- cdata.set('HAVE_STRUCT_CMSGCRED', false)
-endif
-
if cc.has_type('struct option',
args: test_c_args, include_directories: postgres_inc,
prefix: '@0@'.format(cdata.get('HAVE_GETOPT_H')) == '1' ? '#include <getopt.h>' : '')