summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Eisentraut <peter@eisentraut.org>2019-02-09 15:55:17 +0100
committerPeter Eisentraut <peter@eisentraut.org>2019-02-09 15:55:17 +0100
commit4446565d36ac4482282146a9ab35068f18dff4fd (patch)
treec4bc5a10c0a1d9faa7daa7378b8883261b346817 /configure.in
parent356687bd825e5ca7230d43c1bffe7a59ad2e77bd (diff)
downloadpostgresql-4446565d36ac4482282146a9ab35068f18dff4fd.tar.gz
Use better comment marker in Autoconf input
The comment marker "#" is copied to the output, so it's only appropriate for comments that make sense in the shell output. For comments about the Autoconf language, "dnl" should be used.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 3d8888805c..96118b5e46 100644
--- a/configure.in
+++ b/configure.in
@@ -1079,11 +1079,11 @@ fi
# other libraries can pull in the pthread functions as a side-effect. We
# want to use the -pthread or similar flags directly, and not rely on
# the side-effects of linking with some other library.
-#
-# note: We have to use AS_IF here rather than plain if. The AC_CHECK_HEADER
-# invocation below is the first one in the script, and autoconf generates
-# additional code for that, which must not be inside the if-block. AS_IF
-# knows how to do that.
+
+dnl note: We have to use AS_IF here rather than plain if. The AC_CHECK_HEADER
+dnl invocation below is the first one in the script, and autoconf generates
+dnl additional code for that, which must not be inside the if-block. AS_IF
+dnl knows how to do that.
AS_IF([test "$enable_thread_safety" = yes -a "$PORTNAME" != "win32"],
[ # then
AX_PTHREAD # set thread flags
@@ -1564,7 +1564,7 @@ if test "$PORTNAME" != "win32"; then
AH_VERBATIM([_DARWIN_USE_64_BIT_INODE],[])
fi
-# Check for largefile support (must be after AC_SYS_LARGEFILE)
+dnl Check for largefile support (must be after AC_SYS_LARGEFILE)
AC_CHECK_SIZEOF([off_t])
# If we don't have largefile support, can't handle segsize >= 2GB.