summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Eisentraut <peter@eisentraut.org>2022-03-25 08:44:31 +0100
committerPeter Eisentraut <peter@eisentraut.org>2022-03-25 08:56:02 +0100
commit23119d51a14c046dae35ae5e6ad9e35982d044fd (patch)
tree890a141660b21c60d9f6e2fc8efd7944a55673a9 /configure.ac
parent56566835039ac5eed70f188518cef1a7ea0971b2 (diff)
downloadpostgresql-23119d51a14c046dae35ae5e6ad9e35982d044fd.tar.gz
Refactor DLSUFFIX handling
Move DLSUFFIX from makefiles into header files for all platforms. Move the DLSUFFIX assignment from src/makefiles/ to src/templates/, have configure read it, and then substitute it into Makefile.global and pg_config.h. This avoids the need for all makefile rules that need it to locally set CPPFLAGS. It also resolves an inconsistent setup between the two Windows build systems. Reviewed-by: Andres Freund <andres@anarazel.de> Discussion: https://www.postgresql.org/message-id/2f9861fb-8969-9005-7518-b8e60f2bead9@enterprisedb.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 078381e568..68ade8f7a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,9 @@ AC_SUBST(PORTNAME)
need_tas=no
tas_file=dummy.s
+# Default, works for most platforms, override in template file if needed
+DLSUFFIX=".so"
+
##
@@ -721,6 +724,10 @@ else
fi
AC_SUBST(TAS)
+AC_SUBST(DLSUFFIX)dnl
+AC_DEFINE_UNQUOTED([DLSUFFIX], ["$DLSUFFIX"],
+ [Define to the file name extension of dynamically-loadable modules.])
+
#
# Set up pkg_config in case we need it below
#